How To Update or Upgrade CentOS 7.1 / 7.2 / 7.3 / 7.4 / 7.5 / 7.6 to CentOS 7.7 with Easy Steps

In this article, i will take you through the steps to update or upgrade CentOS 7.0 / 7.1 / 7.2 / 7.3 / 7.4 / 7.5 / 7.6 to CentOS 7.7.

CentOS is a Linux distribution that provides a free, community-supported computing platform functionally compatible with its upstream source, Red Hat Enterprise Linux.

How To Update or Upgrade CentOS 7.1 / 7.2 / 7.3 / 7.4 / 7.5 / 7.6 to CentOS 7.7 with Easy Steps 1

Upgrade CentOS 7

Step 1: Check Current OS Version

cat /etc/redhat-release
[root@localhost ~]# cat /etc/redhat-release
CentOS Linux release 7.6.1810 (Core)

Step 2: Make sure backup is taken for entire Apps & Services

If this is production server and you are running your apps and services in this then please make sure to take complete backup once before starting the update in case your apps won’t support the updated packages,you will have your backup.

Step 3: Check for Updates

sudo yum check-update
[root@localhost ~]# sudo yum check-update
Loaded plugins: fastestmirror
Determining fastest mirrors
* base: centos.excellmedia.net
* extras: centos.excellmedia.net
* updates: centos.excellmedia.net
base | 3.6 kB 00:00
extras | 2.9 kB 00:00
updates | 2.9 kB 00:00
(1/4): base/7/x86_64/group_gz | 165 kB 00:00
(2/4): extras/7/x86_64/primary_db | 153 kB 00:00
(3/4): updates/7/x86_64/primary_db | 2.8 MB 00:00
(4/4): base/7/x86_64/primary_db | 6.0 MB 00:04

GeoIP.x86_64 1.5.0-14.el7 base
NetworkManager.x86_64 1:1.18.0-5.el7_7.1 updates
NetworkManager-libnm.x86_64 1:1.18.0-5.el7_7.1 updates
NetworkManager-team.x86_64 1:1.18.0-5.el7_7.1 updates
NetworkManager-tui.x86_64 1:1.18.0-5.el7_7.1 updates
alsa-lib.x86_64 1.1.8-1.el7 base
audit.x86_64 2.8.5-4.el7 base
audit-libs.x86_64 2.8.5-4.el7 base
bash.x86_64 4.2.46-33.el7 base
bind-libs-lite.x86_64 32:9.11.4-9.P2.el7 base
bind-license.noarch 32:9.11.4-9.P2.el7 base
binutils.x86_64 2.27-41.base.el7_7.1 updates
biosdevname.x86_64 0.7.3-2.el7 base
centos-release.x86_64 7-7.1908.0.el7.centos base
chrony.x86_64 3.4-1.el7 base
coreutils.x86_64 8.22-24.el7 base
cronie.x86_64 1.4.11-23.el7 base
cronie-anacron.x86_64 1.4.11-23.el7 base
cryptsetup-libs.x86_64 2.0.3-5.el7 base
curl.x86_64 7.29.0-54.el7 base
dbus.x86_64 1:1.10.24-13.el7_6 base
dbus-libs.x86_64 1:1.10.24-13.el7_6 base
device-mapper.x86_64 7:1.02.158-2.el7_7.2 updates
device-mapper-event.x86_64 7:1.02.158-2.el7_7.2 updates
device-mapper-event-libs.x86_64 7:1.02.158-2.el7_7.2 updates
device-mapper-libs.x86_64 7:1.02.158-2.el7_7.2 updates
device-mapper-persistent-data.x86_64 0.8.5-1.el7 base
dhclient.x86_64 12:4.2.5-77.el7.centos base
dhcp-common.x86_64 12:4.2.5-77.el7.centos base
dhcp-libs.x86_64 12:4.2.5-77.el7.centos base
diffutils.x86_64 3.3-5.el7 base
dmidecode.x86_64 1:3.2-3.el7 base
dracut.x86_64 033-564.el7 base
dracut-config-rescue.x86_64 033-564.el7 base
dracut-network.x86_64 033-564.el7 base
e2fsprogs.x86_64 1.42.9-16.el7 base
e2fsprogs-libs.x86_64 1.42.9-16.el7 base
elfutils-default-yama-scope.noarch 0.176-2.el7 base
elfutils-libelf.x86_64 0.176-2.el7 base
elfutils-libs.x86_64 0.176-2.el7 base
ethtool.x86_64 2:4.8-10.el7 base
firewalld.noarch 0.6.3-2.el7_7.2 updates
firewalld-filesystem.noarch 0.6.3-2.el7_7.2 updates
freetype.x86_64 2.8-14.el7 base
glib2.x86_64 2.56.1-5.el7 base
glibc.x86_64 2.17-292.el7 base
glibc-common.x86_64 2.17-292.el7 base
grub2.x86_64 1:2.02-0.80.el7.centos base
grub2-common.noarch 1:2.02-0.80.el7.centos base
grub2-pc.x86_64 1:2.02-0.80.el7.centos base
grub2-pc-modules.noarch 1:2.02-0.80.el7.centos base
grub2-tools.x86_64 1:2.02-0.80.el7.centos base
grub2-tools-extra.x86_64 1:2.02-0.80.el7.centos base
grub2-tools-minimal.x86_64 1:2.02-0.80.el7.centos base
grubby.x86_64 8.28-26.el7 base
hostname.x86_64 3.13-3.el7_7.1 updates
hwdata.x86_64 0.252-9.3.el7 base
initscripts.x86_64 9.49.47-1.el7 base
iproute.x86_64 4.11.0-25.el7 base
iprutils.x86_64 2.4.17.1-2.el7 base
ipset.x86_64 7.1-1.el7 base
ipset-libs.x86_64 7.1-1.el7 base
iptables.x86_64 1.4.21-33.el7 base
irqbalance.x86_64 3:1.0.7-12.el7 base
iwl100-firmware.noarch 39.31.5.1-72.el7 base
iwl1000-firmware.noarch 1:39.31.5.1-72.el7 base
iwl105-firmware.noarch 18.168.6.1-72.el7 base
iwl135-firmware.noarch 18.168.6.1-72.el7 base
iwl2000-firmware.noarch 18.168.6.1-72.el7 base
iwl2030-firmware.noarch 18.168.6.1-72.el7 base
iwl3160-firmware.noarch 22.0.7.0-72.el7 base
iwl3945-firmware.noarch 15.32.2.9-72.el7 base
iwl4965-firmware.noarch 228.61.2.24-72.el7 base
iwl5000-firmware.noarch 8.83.5.1_1-72.el7 base
iwl5150-firmware.noarch 8.24.2.2-72.el7 base
iwl6000-firmware.noarch 9.221.4.1-72.el7 base
iwl6000g2a-firmware.noarch 17.168.5.3-72.el7 base
iwl6000g2b-firmware.noarch 17.168.5.2-72.el7 base
iwl6050-firmware.noarch 41.28.5.1-72.el7 base
iwl7260-firmware.noarch 22.0.7.0-72.el7 base
iwl7265-firmware.noarch 22.0.7.0-72.el7 base
kernel.x86_64 3.10.0-1062.4.1.el7 updates
kernel-tools.x86_64 3.10.0-1062.4.1.el7 updates
kernel-tools-libs.x86_64 3.10.0-1062.4.1.el7 updates
kexec-tools.x86_64 2.0.15-33.el7 base
kmod.x86_64 20-25.el7 base
kmod-libs.x86_64 20-25.el7 base
kpartx.x86_64 0.4.9-127.el7 base
krb5-libs.x86_64 1.15.1-37.el7_7.2 updates
libblkid.x86_64 2.23.2-61.el7 base
libcap.x86_64 2.22-10.el7 base
libcom_err.x86_64 1.42.9-16.el7 base
libcurl.x86_64 7.29.0-54.el7 base
libdb.x86_64 5.3.21-25.el7 base
libdb-utils.x86_64 5.3.21-25.el7 base
libdrm.x86_64 2.4.97-2.el7 base
libgcc.x86_64 4.8.5-39.el7 base
libgomp.x86_64 4.8.5-39.el7 base
libmount.x86_64 2.23.2-61.el7 base
libndp.x86_64 1.2-9.el7 base
libsmartcols.x86_64 2.23.2-61.el7 base
libss.x86_64 1.42.9-16.el7 base
libssh2.x86_64 1.8.0-3.el7 base
libstdc++.x86_64 4.8.5-39.el7 base
libteam.x86_64 1.27-9.el7 base
libuuid.x86_64 2.23.2-61.el7 base
linux-firmware.noarch 20190429-72.gitddde598.el7 base
lshw.x86_64 B.02.18-13.el7 base
lvm2.x86_64 7:2.02.185-2.el7_7.2 updates
lvm2-libs.x86_64 7:2.02.185-2.el7_7.2 updates
lz4.x86_64 1.7.5-3.el7 base
make.x86_64 1:3.82-24.el7 base
mariadb-libs.x86_64 1:5.5.64-1.el7 base
microcode_ctl.x86_64 2:2.1-53.2.el7_7 updates
nspr.x86_64 4.21.0-1.el7 base
nss.x86_64 3.44.0-4.el7 base
nss-pem.x86_64 1.0.3-7.el7 base
nss-softokn.x86_64 3.44.0-5.el7 base
nss-softokn-freebl.x86_64 3.44.0-5.el7 base
nss-sysinit.x86_64 3.44.0-4.el7 base
nss-tools.x86_64 3.44.0-4.el7 base
nss-util.x86_64 3.44.0-3.el7 base
numactl-libs.x86_64 2.0.12-3.el7 base
openldap.x86_64 2.4.44-21.el7_6 base
openssh.x86_64 7.4p1-21.el7 base
openssh-clients.x86_64 7.4p1-21.el7 base
openssh-server.x86_64 7.4p1-21.el7 base
openssl.x86_64 1:1.0.2k-19.el7 base
openssl-libs.x86_64 1:1.0.2k-19.el7 base
parted.x86_64 3.1-31.el7 base
passwd.x86_64 0.79-5.el7 base
plymouth.x86_64 0.8.9-0.32.20140113.el7.centos base
plymouth-core-libs.x86_64 0.8.9-0.32.20140113.el7.centos base
plymouth-scripts.x86_64 0.8.9-0.32.20140113.el7.centos base
policycoreutils.x86_64 2.5-33.el7 base
polkit.x86_64 0.112-22.el7_7.1 updates
procps-ng.x86_64 3.3.10-26.el7_7.1 updates
python.x86_64 2.7.5-86.el7 base
python-firewall.noarch 0.6.3-2.el7_7.2 updates
python-libs.x86_64 2.7.5-86.el7 base
python-linux-procfs.noarch 0.4.11-4.el7 base
python-perf.x86_64 3.10.0-1062.4.1.el7 updates
qemu-guest-agent.x86_64 10:2.12.0-3.el7 base
readline.x86_64 6.2-11.el7 base
rpm.x86_64 4.11.3-40.el7 base
rpm-build-libs.x86_64 4.11.3-40.el7 base
rpm-libs.x86_64 4.11.3-40.el7 base
rpm-python.x86_64 4.11.3-40.el7 base
rsyslog.x86_64 8.24.0-41.el7_7.2 updates
selinux-policy.noarch 3.13.1-252.el7.1 updates
selinux-policy-targeted.noarch 3.13.1-252.el7.1 updates
sg3_utils.x86_64 1.37-18.el7_7.1 updates
sg3_utils-libs.x86_64 1.37-18.el7_7.1 updates
shadow-utils.x86_64 2:4.6-5.el7 base
sudo.x86_64 1.8.23-4.el7_7.1 updates
systemd.x86_64 219-67.el7_7.2 updates
systemd-libs.x86_64 219-67.el7_7.2 updates
systemd-sysv.x86_64 219-67.el7_7.2 updates
teamd.x86_64 1.27-9.el7 base
tuned.noarch 2.11.0-5.el7_7.1 updates
tzdata.noarch 2019c-1.el7 updates
util-linux.x86_64 2.23.2-61.el7 base
vim-minimal.x86_64 2:7.4.629-6.el7 base
xfsprogs.x86_64 4.5.0-20.el7 base
yum.noarch 3.4.3-163.el7.centos base
yum-plugin-fastestmirror.noarch 1.1.31-52.el7 bas

Step 4: Clean up yum package manager 

yum packager manager store the local listings and metadata of previous installed packages. It is necessary to run the clean up once to remove all those past cached data.

sudo yum clean all
[root@localhost ~]# sudo yum clean all
Loaded plugins: fastestmirror
Cleaning repos: base extras updates
Cleaning up list of fastest mirrors

Step 5: Reboot the Server after Clean Up

To clean up the local cache and repository you need to reboot the server once. It will also speed up the process and will avoid any unnecessary issues.

reboot

Use the below command to reboot the Server:

#reboot

Step 6: Upgrade the CentOS to latest release

sudo yum upgrade
[root@localhost ~]# sudo yum update
Loaded plugins: fastestmirror
Determining fastest mirrors
* base: centos.excellmedia.net
* extras: centos.excellmedia.net
* updates: centos.excellmedia.net
base | 3.6 kB 00:00:00
extras | 2.9 kB 00:00:00
updates | 2.9 kB 00:00:00
(1/4): extras/7/x86_64/primary_db | 153 kB 00:00:00
(2/4): base/7/x86_64/group_gz | 165 kB 00:00:00
(3/4): updates/7/x86_64/primary_db | 2.8 MB 00:00:00
(4/4): base/7/x86_64/primary_db | 6.0 MB 00:00:01
Resolving Dependencies
--> Running transaction check
---> Package GeoIP.x86_64 0:1.5.0-13.el7 will be updated
---> Package GeoIP.x86_64 0:1.5.0-14.el7 will be an update
--> Processing Dependency: geoipupdate for package: GeoIP-1.5.0-14.el7.x86_64
---> Package NetworkManager.x86_64 1:1.12.0-6.el7 will be updated
---> Package NetworkManager.x86_64 1:1.18.0-5.el7_7.1 will be an update
---> Package NetworkManager-libnm.x86_64 1:1.12.0-6.el7 will be updated
---> Package NetworkManager-libnm.x86_64 1:1.18.0-5.el7_7.1 will be an update
---> Package NetworkManager-team.x86_64 1:1.12.0-6.el7 will be updated
---> Package NetworkManager-team.x86_64 1:1.18.0-5.el7_7.1 will be an update
---> Package NetworkManager-tui.x86_64 1:1.12.0-6.el7 will be updated
---> Package NetworkManager-tui.x86_64 1:1.18.0-5.el7_7.1 will be an update
---> Package alsa-lib.x86_64 0:1.1.6-2.el7 will be updated
---> Package alsa-lib.x86_64 0:1.1.8-1.el7 will be an update
---> Package audit.x86_64 0:2.8.4-4.el7 will be updated
---> Package audit.x86_64 0:2.8.5-4.el7 will be an update
---> Package audit-libs.x86_64 0:2.8.4-4.el7 will be updated
---> Package audit-libs.x86_64 0:2.8.5-4.el7 will be an update
---> Package bash.x86_64 0:4.2.46-31.el7 will be updated
---> Package bash.x86_64 0:4.2.46-33.el7 will be an update
---> Package bind-libs-lite.x86_64 32:9.9.4-72.el7 will be updated
---> Package bind-libs-lite.x86_64 32:9.11.4-9.P2.el7 will be an update
---> Package bind-license.noarch 32:9.9.4-72.el7 will be updated
---> Package bind-license.noarch 32:9.11.4-9.P2.el7 will be an update
---> Package binutils.x86_64 0:2.27-34.base.el7 will be updated
---> Package binutils.x86_64 0:2.27-41.base.el7_7.1 will be an update
---> Package biosdevname.x86_64 0:0.7.3-1.el7 will be updated
---> Package biosdevname.x86_64 0:0.7.3-2.el7 will be an update
---> Package centos-release.x86_64 0:7-6.1810.2.el7.centos will be updated
---> Package centos-release.x86_64 0:7-7.1908.0.el7.centos will be an update
---> Package chrony.x86_64 0:3.2-2.el7 will be updated
---> Package chrony.x86_64 0:3.4-1.el7 will be an update
---> Package coreutils.x86_64 0:8.22-23.el7 will be updated
---> Package coreutils.x86_64 0:8.22-24.el7 will be an update
---> Package cronie.x86_64 0:1.4.11-19.el7 will be updated
---> Package cronie.x86_64 0:1.4.11-23.el7 will be an update
---> Package cronie-anacron.x86_64 0:1.4.11-19.el7 will be updated
---> Package cronie-anacron.x86_64 0:1.4.11-23.el7 will be an update
---> Package cryptsetup-libs.x86_64 0:2.0.3-3.el7 will be updated
---> Package cryptsetup-libs.x86_64 0:2.0.3-5.el7 will be an update
---> Package curl.x86_64 0:7.29.0-51.el7 will be updated
---> Package curl.x86_64 0:7.29.0-54.el7 will be an update
---> Package dbus.x86_64 1:1.10.24-12.el7 will be updated
---> Package dbus.x86_64 1:1.10.24-13.el7_6 will be an update
---> Package dbus-libs.x86_64 1:1.10.24-12.el7 will be updated
---> Package dbus-libs.x86_64 1:1.10.24-13.el7_6 will be an update
---> Package device-mapper.x86_64 7:1.02.149-8.el7 will be updated
---> Package device-mapper.x86_64 7:1.02.158-2.el7_7.2 will be an update
---> Package device-mapper-event.x86_64 7:1.02.149-8.el7 will be updated
---> Package device-mapper-event.x86_64 7:1.02.158-2.el7_7.2 will be an update
---> Package device-mapper-event-libs.x86_64 7:1.02.149-8.el7 will be updated
---> Package device-mapper-event-libs.x86_64 7:1.02.158-2.el7_7.2 will be an update
---> Package device-mapper-libs.x86_64 7:1.02.149-8.el7 will be updated
---> Package device-mapper-libs.x86_64 7:1.02.158-2.el7_7.2 will be an update
---> Package device-mapper-persistent-data.x86_64 0:0.7.3-3.el7 will be updated
---> Package device-mapper-persistent-data.x86_64 0:0.8.5-1.el7 will be an update
---> Package dhclient.x86_64 12:4.2.5-68.el7.centos.1 will be updated
---> Package dhclient.x86_64 12:4.2.5-77.el7.centos will be an update
--> Processing Dependency: libisc-export.so.169()(64bit) for package: 12:dhclient-4.2.5-77.el7.centos.x86_64
--> Processing Dependency: libdns-export.so.1102()(64bit) for package: 12:dhclient-4.2.5-77.el7.centos.x86_64
---> Package dhcp-common.x86_64 12:4.2.5-68.el7.centos.1 will be updated
---> Package dhcp-common.x86_64 12:4.2.5-77.el7.centos will be an update
---> Package dhcp-libs.x86_64 12:4.2.5-68.el7.centos.1 will be updated
---> Package dhcp-libs.x86_64 12:4.2.5-77.el7.centos will be an update
---> Package diffutils.x86_64 0:3.3-4.el7 will be updated
---> Package diffutils.x86_64 0:3.3-5.el7 will be an update
---> Package dmidecode.x86_64 1:3.1-2.el7 will be updated
---> Package dmidecode.x86_64 1:3.2-3.el7 will be an update
---> Package dracut.x86_64 0:033-554.el7 will be updated
---> Package dracut.x86_64 0:033-564.el7 will be an update
---> Package dracut-config-rescue.x86_64 0:033-554.el7 will be updated
---> Package dracut-config-rescue.x86_64 0:033-564.el7 will be an update
---> Package dracut-network.x86_64 0:033-554.el7 will be updated
---> Package dracut-network.x86_64 0:033-564.el7 will be an update
---> Package e2fsprogs.x86_64 0:1.42.9-13.el7 will be updated
---> Package e2fsprogs.x86_64 0:1.42.9-16.el7 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.42.9-13.el7 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.42.9-16.el7 will be an update
---> Package elfutils-default-yama-scope.noarch 0:0.172-2.el7 will be updated
---> Package elfutils-default-yama-scope.noarch 0:0.176-2.el7 will be an update
---> Package elfutils-libelf.x86_64 0:0.172-2.el7 will be updated
---> Package elfutils-libelf.x86_64 0:0.176-2.el7 will be an update
---> Package elfutils-libs.x86_64 0:0.172-2.el7 will be updated
---> Package elfutils-libs.x86_64 0:0.176-2.el7 will be an update
---> Package ethtool.x86_64 2:4.8-9.el7 will be updated
---> Package ethtool.x86_64 2:4.8-10.el7 will be an update
---> Package firewalld.noarch 0:0.5.3-5.el7 will be updated
---> Package firewalld.noarch 0:0.6.3-2.el7_7.2 will be an update
---> Package firewalld-filesystem.noarch 0:0.5.3-5.el7 will be updated
---> Package firewalld-filesystem.noarch 0:0.6.3-2.el7_7.2 will be an update
---> Package freetype.x86_64 0:2.8-12.el7 will be updated
---> Package freetype.x86_64 0:2.8-14.el7 will be an update
---> Package glib2.x86_64 0:2.56.1-2.el7 will be updated
---> Package glib2.x86_64 0:2.56.1-5.el7 will be an update
---> Package glibc.x86_64 0:2.17-260.el7 will be updated
---> Package glibc.x86_64 0:2.17-292.el7 will be an update
---> Package glibc-common.x86_64 0:2.17-260.el7 will be updated
---> Package glibc-common.x86_64 0:2.17-292.el7 will be an update
---> Package grub2.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2.x86_64 1:2.02-0.80.el7.centos will be an update
---> Package grub2-common.noarch 1:2.02-0.76.el7.centos will be updated
---> Package grub2-common.noarch 1:2.02-0.80.el7.centos will be an update
---> Package grub2-pc.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2-pc.x86_64 1:2.02-0.80.el7.centos will be an update
---> Package grub2-pc-modules.noarch 1:2.02-0.76.el7.centos will be updated
---> Package grub2-pc-modules.noarch 1:2.02-0.80.el7.centos will be an update
---> Package grub2-tools.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2-tools.x86_64 1:2.02-0.80.el7.centos will be an update
---> Package grub2-tools-extra.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2-tools-extra.x86_64 1:2.02-0.80.el7.centos will be an update
---> Package grub2-tools-minimal.x86_64 1:2.02-0.76.el7.centos will be updated
---> Package grub2-tools-minimal.x86_64 1:2.02-0.80.el7.centos will be an update
---> Package grubby.x86_64 0:8.28-25.el7 will be updated
---> Package grubby.x86_64 0:8.28-26.el7 will be an update
---> Package hostname.x86_64 0:3.13-3.el7 will be updated
---> Package hostname.x86_64 0:3.13-3.el7_7.1 will be an update
---> Package hwdata.x86_64 0:0.252-9.1.el7 will be updated
---> Package hwdata.x86_64 0:0.252-9.3.el7 will be an update
---> Package initscripts.x86_64 0:9.49.46-1.el7 will be updated
---> Package initscripts.x86_64 0:9.49.47-1.el7 will be an update
---> Package iproute.x86_64 0:4.11.0-14.el7 will be updated
---> Package iproute.x86_64 0:4.11.0-25.el7 will be an update
---> Package iprutils.x86_64 0:2.4.16.1-1.el7 will be updated
---> Package iprutils.x86_64 0:2.4.17.1-2.el7 will be an update
---> Package ipset.x86_64 0:6.38-2.el7 will be updated
---> Package ipset.x86_64 0:7.1-1.el7 will be an update
---> Package ipset-libs.x86_64 0:6.38-2.el7 will be updated
---> Package ipset-libs.x86_64 0:7.1-1.el7 will be an update
---> Package iptables.x86_64 0:1.4.21-28.el7 will be updated
---> Package iptables.x86_64 0:1.4.21-33.el7 will be an update
---> Package irqbalance.x86_64 3:1.0.7-11.el7 will be updated
---> Package irqbalance.x86_64 3:1.0.7-12.el7 will be an update
---> Package iwl100-firmware.noarch 0:39.31.5.1-69.el7 will be updated
---> Package iwl100-firmware.noarch 0:39.31.5.1-72.el7 will be an update
---> Package iwl1000-firmware.noarch 1:39.31.5.1-69.el7 will be updated
---> Package iwl1000-firmware.noarch 1:39.31.5.1-72.el7 will be an update
---> Package iwl105-firmware.noarch 0:18.168.6.1-69.el7 will be updated
---> Package iwl105-firmware.noarch 0:18.168.6.1-72.el7 will be an update
---> Package iwl135-firmware.noarch 0:18.168.6.1-69.el7 will be updated
---> Package iwl135-firmware.noarch 0:18.168.6.1-72.el7 will be an update
---> Package iwl2000-firmware.noarch 0:18.168.6.1-69.el7 will be updated
---> Package iwl2000-firmware.noarch 0:18.168.6.1-72.el7 will be an update
---> Package iwl2030-firmware.noarch 0:18.168.6.1-69.el7 will be updated
---> Package iwl2030-firmware.noarch 0:18.168.6.1-72.el7 will be an update
---> Package iwl3160-firmware.noarch 0:22.0.7.0-69.el7 will be updated
---> Package iwl3160-firmware.noarch 0:22.0.7.0-72.el7 will be an update
---> Package iwl3945-firmware.noarch 0:15.32.2.9-69.el7 will be updated
---> Package iwl3945-firmware.noarch 0:15.32.2.9-72.el7 will be an update
---> Package iwl4965-firmware.noarch 0:228.61.2.24-69.el7 will be updated
---> Package iwl4965-firmware.noarch 0:228.61.2.24-72.el7 will be an update
---> Package iwl5000-firmware.noarch 0:8.83.5.1_1-69.el7 will be updated
---> Package iwl5000-firmware.noarch 0:8.83.5.1_1-72.el7 will be an update
---> Package iwl5150-firmware.noarch 0:8.24.2.2-69.el7 will be updated
---> Package iwl5150-firmware.noarch 0:8.24.2.2-72.el7 will be an update
---> Package iwl6000-firmware.noarch 0:9.221.4.1-69.el7 will be updated
---> Package iwl6000-firmware.noarch 0:9.221.4.1-72.el7 will be an update
---> Package iwl6000g2a-firmware.noarch 0:17.168.5.3-69.el7 will be updated
---> Package iwl6000g2a-firmware.noarch 0:17.168.5.3-72.el7 will be an update
---> Package iwl6000g2b-firmware.noarch 0:17.168.5.2-69.el7 will be updated
---> Package iwl6000g2b-firmware.noarch 0:17.168.5.2-72.el7 will be an update
---> Package iwl6050-firmware.noarch 0:41.28.5.1-69.el7 will be updated
---> Package iwl6050-firmware.noarch 0:41.28.5.1-72.el7 will be an update
---> Package iwl7260-firmware.noarch 0:22.0.7.0-69.el7 will be updated
---> Package iwl7260-firmware.noarch 0:22.0.7.0-72.el7 will be an update
---> Package iwl7265-firmware.noarch 0:22.0.7.0-69.el7 will be updated
---> Package iwl7265-firmware.noarch 0:22.0.7.0-72.el7 will be an update
---> Package kernel.x86_64 0:3.10.0-1062.4.1.el7 will be installed
---> Package kernel-tools.x86_64 0:3.10.0-957.el7 will be updated
---> Package kernel-tools.x86_64 0:3.10.0-1062.4.1.el7 will be an update
---> Package kernel-tools-libs.x86_64 0:3.10.0-957.el7 will be updated
---> Package kernel-tools-libs.x86_64 0:3.10.0-1062.4.1.el7 will be an update
---> Package kexec-tools.x86_64 0:2.0.15-21.el7 will be updated
---> Package kexec-tools.x86_64 0:2.0.15-33.el7 will be an update
---> Package kmod.x86_64 0:20-23.el7 will be updated
---> Package kmod.x86_64 0:20-25.el7 will be an update
---> Package kmod-libs.x86_64 0:20-23.el7 will be updated
---> Package kmod-libs.x86_64 0:20-25.el7 will be an update
---> Package kpartx.x86_64 0:0.4.9-123.el7 will be updated
---> Package kpartx.x86_64 0:0.4.9-127.el7 will be an update
---> Package krb5-libs.x86_64 0:1.15.1-34.el7 will be updated
---> Package krb5-libs.x86_64 0:1.15.1-37.el7_7.2 will be an update
---> Package libblkid.x86_64 0:2.23.2-59.el7 will be updated
---> Package libblkid.x86_64 0:2.23.2-61.el7 will be an update
---> Package libcap.x86_64 0:2.22-9.el7 will be updated
---> Package libcap.x86_64 0:2.22-10.el7 will be an update
---> Package libcom_err.x86_64 0:1.42.9-13.el7 will be updated
---> Package libcom_err.x86_64 0:1.42.9-16.el7 will be an update
---> Package libcurl.x86_64 0:7.29.0-51.el7 will be updated
---> Package libcurl.x86_64 0:7.29.0-54.el7 will be an update
---> Package libdb.x86_64 0:5.3.21-24.el7 will be updated
---> Package libdb.x86_64 0:5.3.21-25.el7 will be an update
---> Package libdb-utils.x86_64 0:5.3.21-24.el7 will be updated
---> Package libdb-utils.x86_64 0:5.3.21-25.el7 will be an update
---> Package libdrm.x86_64 0:2.4.91-3.el7 will be updated
---> Package libdrm.x86_64 0:2.4.97-2.el7 will be an update
---> Package libgcc.x86_64 0:4.8.5-36.el7 will be updated
---> Package libgcc.x86_64 0:4.8.5-39.el7 will be an update
---> Package libgomp.x86_64 0:4.8.5-36.el7 will be updated
---> Package libgomp.x86_64 0:4.8.5-39.el7 will be an update
---> Package libmount.x86_64 0:2.23.2-59.el7 will be updated
---> Package libmount.x86_64 0:2.23.2-61.el7 will be an update
---> Package libndp.x86_64 0:1.2-7.el7 will be updated
---> Package libndp.x86_64 0:1.2-9.el7 will be an update
---> Package libsmartcols.x86_64 0:2.23.2-59.el7 will be updated
---> Package libsmartcols.x86_64 0:2.23.2-61.el7 will be an update
---> Package libss.x86_64 0:1.42.9-13.el7 will be updated
---> Package libss.x86_64 0:1.42.9-16.el7 will be an update
---> Package libssh2.x86_64 0:1.4.3-12.el7 will be updated
---> Package libssh2.x86_64 0:1.8.0-3.el7 will be an update
---> Package libstdc++.x86_64 0:4.8.5-36.el7 will be updated
---> Package libstdc++.x86_64 0:4.8.5-39.el7 will be an update
---> Package libteam.x86_64 0:1.27-5.el7 will be updated
---> Package libteam.x86_64 0:1.27-9.el7 will be an update
---> Package libuuid.x86_64 0:2.23.2-59.el7 will be updated
---> Package libuuid.x86_64 0:2.23.2-61.el7 will be an update
---> Package linux-firmware.noarch 0:20180911-69.git85c5d90.el7 will be updated
---> Package linux-firmware.noarch 0:20190429-72.gitddde598.el7 will be an update
---> Package lshw.x86_64 0:B.02.18-12.el7 will be updated
---> Package lshw.x86_64 0:B.02.18-13.el7 will be an update
---> Package lvm2.x86_64 7:2.02.180-8.el7 will be updated
---> Package lvm2.x86_64 7:2.02.185-2.el7_7.2 will be an update
---> Package lvm2-libs.x86_64 7:2.02.180-8.el7 will be updated
---> Package lvm2-libs.x86_64 7:2.02.185-2.el7_7.2 will be an update
---> Package lz4.x86_64 0:1.7.5-2.el7 will be updated
---> Package lz4.x86_64 0:1.7.5-3.el7 will be an update
---> Package make.x86_64 1:3.82-23.el7 will be updated
---> Package make.x86_64 1:3.82-24.el7 will be an update
---> Package mariadb-libs.x86_64 1:5.5.60-1.el7_5 will be updated
---> Package mariadb-libs.x86_64 1:5.5.64-1.el7 will be an update
---> Package microcode_ctl.x86_64 2:2.1-47.el7 will be updated
---> Package microcode_ctl.x86_64 2:2.1-53.2.el7_7 will be an update
---> Package nspr.x86_64 0:4.19.0-1.el7_5 will be updated
---> Package nspr.x86_64 0:4.21.0-1.el7 will be an update
---> Package nss.x86_64 0:3.36.0-7.el7_5 will be updated
---> Package nss.x86_64 0:3.44.0-4.el7 will be an update
---> Package nss-pem.x86_64 0:1.0.3-5.el7 will be updated
---> Package nss-pem.x86_64 0:1.0.3-7.el7 will be an update
---> Package nss-softokn.x86_64 0:3.36.0-5.el7_5 will be updated
---> Package nss-softokn.x86_64 0:3.44.0-5.el7 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.36.0-5.el7_5 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.44.0-5.el7 will be an update
---> Package nss-sysinit.x86_64 0:3.36.0-7.el7_5 will be updated
---> Package nss-sysinit.x86_64 0:3.44.0-4.el7 will be an update
---> Package nss-tools.x86_64 0:3.36.0-7.el7_5 will be updated
---> Package nss-tools.x86_64 0:3.44.0-4.el7 will be an update
---> Package nss-util.x86_64 0:3.36.0-1.el7_5 will be updated
---> Package nss-util.x86_64 0:3.44.0-3.el7 will be an update
---> Package numactl-libs.x86_64 0:2.0.9-7.el7 will be updated
---> Package numactl-libs.x86_64 0:2.0.12-3.el7 will be an update
---> Package openldap.x86_64 0:2.4.44-20.el7 will be updated
---> Package openldap.x86_64 0:2.4.44-21.el7_6 will be an update
---> Package openssh.x86_64 0:7.4p1-16.el7 will be updated
---> Package openssh.x86_64 0:7.4p1-21.el7 will be an update
---> Package openssh-clients.x86_64 0:7.4p1-16.el7 will be updated
---> Package openssh-clients.x86_64 0:7.4p1-21.el7 will be an update
---> Package openssh-server.x86_64 0:7.4p1-16.el7 will be updated
---> Package openssh-server.x86_64 0:7.4p1-21.el7 will be an update
---> Package openssl.x86_64 1:1.0.2k-16.el7 will be updated
---> Package openssl.x86_64 1:1.0.2k-19.el7 will be an update
---> Package openssl-libs.x86_64 1:1.0.2k-16.el7 will be updated
---> Package openssl-libs.x86_64 1:1.0.2k-19.el7 will be an update
---> Package parted.x86_64 0:3.1-29.el7 will be updated
---> Package parted.x86_64 0:3.1-31.el7 will be an update
---> Package passwd.x86_64 0:0.79-4.el7 will be updated
---> Package passwd.x86_64 0:0.79-5.el7 will be an update
---> Package plymouth.x86_64 0:0.8.9-0.31.20140113.el7.centos will be updated
---> Package plymouth.x86_64 0:0.8.9-0.32.20140113.el7.centos will be an update
---> Package plymouth-core-libs.x86_64 0:0.8.9-0.31.20140113.el7.centos will be updated
---> Package plymouth-core-libs.x86_64 0:0.8.9-0.32.20140113.el7.centos will be an update
---> Package plymouth-scripts.x86_64 0:0.8.9-0.31.20140113.el7.centos will be updated
---> Package plymouth-scripts.x86_64 0:0.8.9-0.32.20140113.el7.centos will be an update
---> Package policycoreutils.x86_64 0:2.5-29.el7 will be updated
---> Package policycoreutils.x86_64 0:2.5-33.el7 will be an update
---> Package polkit.x86_64 0:0.112-18.el7 will be updated
---> Package polkit.x86_64 0:0.112-22.el7_7.1 will be an update
---> Package procps-ng.x86_64 0:3.3.10-23.el7 will be updated
---> Package procps-ng.x86_64 0:3.3.10-26.el7_7.1 will be an update
---> Package python.x86_64 0:2.7.5-76.el7 will be updated
---> Package python.x86_64 0:2.7.5-86.el7 will be an update
---> Package python-firewall.noarch 0:0.5.3-5.el7 will be updated
---> Package python-firewall.noarch 0:0.6.3-2.el7_7.2 will be an update
---> Package python-libs.x86_64 0:2.7.5-76.el7 will be updated
---> Package python-libs.x86_64 0:2.7.5-86.el7 will be an update
---> Package python-linux-procfs.noarch 0:0.4.9-4.el7 will be updated
---> Package python-linux-procfs.noarch 0:0.4.11-4.el7 will be an update
---> Package python-perf.x86_64 0:3.10.0-957.el7 will be updated
---> Package python-perf.x86_64 0:3.10.0-1062.4.1.el7 will be an update
---> Package qemu-guest-agent.x86_64 10:2.12.0-2.el7 will be updated
---> Package qemu-guest-agent.x86_64 10:2.12.0-3.el7 will be an update
---> Package readline.x86_64 0:6.2-10.el7 will be updated
---> Package readline.x86_64 0:6.2-11.el7 will be an update
---> Package rpm.x86_64 0:4.11.3-35.el7 will be updated
---> Package rpm.x86_64 0:4.11.3-40.el7 will be an update
---> Package rpm-build-libs.x86_64 0:4.11.3-35.el7 will be updated
---> Package rpm-build-libs.x86_64 0:4.11.3-40.el7 will be an update
---> Package rpm-libs.x86_64 0:4.11.3-35.el7 will be updated
---> Package rpm-libs.x86_64 0:4.11.3-40.el7 will be an update
---> Package rpm-python.x86_64 0:4.11.3-35.el7 will be updated
---> Package rpm-python.x86_64 0:4.11.3-40.el7 will be an update
---> Package rsyslog.x86_64 0:8.24.0-34.el7 will be updated
---> Package rsyslog.x86_64 0:8.24.0-41.el7_7.2 will be an update
---> Package selinux-policy.noarch 0:3.13.1-229.el7 will be updated
---> Package selinux-policy.noarch 0:3.13.1-252.el7.1 will be an update
---> Package selinux-policy-targeted.noarch 0:3.13.1-229.el7 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-252.el7.1 will be an update
---> Package sg3_utils.x86_64 0:1.37-17.el7 will be updated
---> Package sg3_utils.x86_64 0:1.37-18.el7_7.1 will be an update
---> Package sg3_utils-libs.x86_64 0:1.37-17.el7 will be updated
---> Package sg3_utils-libs.x86_64 0:1.37-18.el7_7.1 will be an update
---> Package shadow-utils.x86_64 2:4.1.5.1-25.el7 will be updated
---> Package shadow-utils.x86_64 2:4.6-5.el7 will be an update
---> Package sudo.x86_64 0:1.8.23-3.el7 will be updated
---> Package sudo.x86_64 0:1.8.23-4.el7_7.1 will be an update
---> Package systemd.x86_64 0:219-62.el7 will be updated
---> Package systemd.x86_64 0:219-67.el7_7.2 will be an update
---> Package systemd-libs.x86_64 0:219-62.el7 will be updated
---> Package systemd-libs.x86_64 0:219-67.el7_7.2 will be an update
---> Package systemd-sysv.x86_64 0:219-62.el7 will be updated
---> Package systemd-sysv.x86_64 0:219-67.el7_7.2 will be an update
---> Package teamd.x86_64 0:1.27-5.el7 will be updated
---> Package teamd.x86_64 0:1.27-9.el7 will be an update
---> Package tuned.noarch 0:2.10.0-6.el7 will be updated
---> Package tuned.noarch 0:2.11.0-5.el7_7.1 will be an update
---> Package tzdata.noarch 0:2018e-3.el7 will be updated
---> Package tzdata.noarch 0:2019c-1.el7 will be an update
---> Package util-linux.x86_64 0:2.23.2-59.el7 will be updated
---> Package util-linux.x86_64 0:2.23.2-61.el7 will be an update
---> Package vim-minimal.x86_64 2:7.4.160-5.el7 will be updated
---> Package vim-minimal.x86_64 2:7.4.629-6.el7 will be an update
---> Package xfsprogs.x86_64 0:4.5.0-18.el7 will be updated
---> Package xfsprogs.x86_64 0:4.5.0-20.el7 will be an update
---> Package yum.noarch 0:3.4.3-161.el7.centos will be updated
---> Package yum.noarch 0:3.4.3-163.el7.centos will be an update
---> Package yum-plugin-fastestmirror.noarch 0:1.1.31-50.el7 will be updated
---> Package yum-plugin-fastestmirror.noarch 0:1.1.31-52.el7 will be an update
--> Running transaction check
---> Package bind-export-libs.x86_64 32:9.11.4-9.P2.el7 will be installed
---> Package geoipupdate.x86_64 0:2.5.0-1.el7 will be installed
--> Finished Dependency Resolution

Then perform reboot once.

Advertisements
#sudo reboot

Step 7: Check the CentOS Version

Verify if CentOS is upgraded to latest version.

cat /etc/redhat-release
[root@localhost ~]# cat /etc/redhat-release
CentOS Linux release 7.7.1908 (Core)

Also Read: How to install Docker on CentOS 7

To check latest CentOS Version: http://mirror.centos.org/ 

Advertisements

Leave a Reply